Does This plugin requires BuddyPress?

Yes, It needs you to have BuddyPress installed and activated and the BuddyPress notifications component must be enabled.